在vim上安装YouCompleteMe的记录

准备
cmake (mac可以通过homebrew安装,brew install cmake,ubuntu可以通过sudo apt-get install cmake, centos下就是 yun install cmake)
Vundle 参考 https://github.com/VundleVim/Vundle.vim ,也可用pathogen来管理插件,这里使用Vundle

安装 YouCompleteMe
在文件 .vimrc 中添加
Bundle 'Valloric/YouCompleteMe'
然后进入 vim 输入
:BundleInstall

然后到目录
~/.vim/bundle/YouCompleteMe
运行
install.sh 或 install.py

安装成功后,就可以享受如果丝滑般的。。。。。

这里说明下:
安装的时候,vim的窗口没有进程条之类的,只是在最下方 显示
Processing 'Valloric/YouCompleteMe'
还以为出什么问题了呢,后来查看了下网络,发现在下载东西呢,所以就放心地继续等

##### 如果下载没有动静,可以试试科学上网 ######

可能遇到的问题: python3 需要下面这个库,编译的时候得加上 --enable-shared

/usr/local/lib/python3.4/config-3.4m/libpython3.4m.a

如果还遇到什么问题欢迎留言,一起讨论

参考:
YouCompleteMe — Ultimate Autocomplete Plugin for Vim
Vundle, the plug-in manager for Vim

标签: vim, youcompleteme

添加新评论